[openstack-dev] [diskimage-builder] ERROR: embedding is not possible, but this is required for cross-disk install

Jay Pipes jaypipes at gmail.com
Mon Jun 20 22:36:36 UTC 2016

On 06/20/2016 06:24 PM, Gregory Haynes wrote:
> On Mon, Jun 20, 2016, at 03:52 PM, Jay Pipes wrote:
>> Hi dib-gurus,
>> I'm trying to build a simple ubuntu VM image on a local Gigabyte BRIX
>> with a AMD A8-5557M APU with Ubuntu 16.04 installed and getting an odd
>> error. Hoping someone has some ideas...
>> The command I am running is:
>> disk-image-create -o /tmp/ubuntu.qcow2 --image-size=10 ubuntu vm
>> Everything goes smoothly until trying to write the MBR, at which point I
>> get the following error:
>> + /usr/sbin/grub-install '--modules=biosdisk part_msdos'
>> --target=i386-pc /dev/loop0
>> Installing for i386-pc platform.
>> /usr/sbin/grub-install: warning: this msdos-style partition label has no
>> post-MBR gap; embedding won't be possible.
>> /usr/sbin/grub-install: error: embedding is not possible, but this is
>> required for cross-disk install.
>> /dev/loop0: [0047]:3 (/tmp/image.hk8wiFJe/image.raw)
>> Anybody got any ideas?
>> Thanks in advance!
>> -jay
> Hey Jay,
> I just tried to reproduce this on my 14.04 box and wasn't able to so I
> am betting there's some kind of new bug with us on 16.04. Do you get the
> same error if you run without --image-size=10? Last time we had an issue
> like this a new grub version changed the default behavior, so I'd
> suspect something along those lines.
> I am trying out a new run on a 16.04 box but its going to be a bit
> before the cloud image downloads (cloud-image.ubuntu.com is pretty
> slow)...

Thanks, Greg! Yeah, I guessed it might be something to do with the 
target image size maybe being too small or something, so I retried 
without the --image-size and got the same result. So, must be something 


More information about the OpenStack-dev mailing list