[openstack-dev] [Horizon][stable] Horizon kilo gate fails due to testrepository dependency

Matthias Runge mrunge at redhat.com
Mon Jan 4 12:24:42 UTC 2016

On Mon, Jan 04, 2016 at 12:29:27PM +0100, Ihar Hrachyshka wrote:
> Matthias Runge <mrunge at redhat.com> wrote:
> >testrepository
> >
> >Any suggestions here?
> Seems like pbr importing testrepository, hence the dependency belongs to
> pbr, not horizon (and as a runtime dependency, not just test only).
> But note that since pbr 1.1.0, they no longer depend on the package and fail
> gracefully:
> https://github.com/openstack-dev/pbr/commit/946cf80b750f3735a5d3b0c2173f4eaa7fad4a81
> So the proper way would be indeed to make your package to install testr for
> tests. Not sure why it worked before, but I would bet that some other
> components installed it for you (devstack? devstack-gate? job definition?
> some other component previously installed before keystone? Not that it’s too
> important.)
> Ihar

Thank you.

I'm a bit confused, why it worked before e.g Dec 20th last year, but
fails after.
And it's only failing in kilo, not on liberty.

And even when adding testrepository to test-requirements, it fails,
because it's missing?

If pbr uses testrepository at run-time, it should be pulled in as
run-time requirement.
Matthias Runge <mrunge at redhat.com>

More information about the OpenStack-dev mailing list