[openstack-dev] [nova][cinder] Fix nova swap volume (updating an attached volume) function

Takashi Natsume natsume.takashi at lab.ntt.co.jp
Thu Feb 25 11:31:11 UTC 2016

Hi Nova and Cinder developers.

As I reported in a bug report [1], nova swap volume
(updating an attached volume) fuction does not work
in the case of non admin users by default. 
(Volumes are stuck.)

Before I was working for fixing another swap volume bug [2][3].
But Ryan fixed it on the Cinder side [4].
As a result, admin users can execute swap volume function,
but it was not fixed in the case of non admin users.
So I reported the bug report [1].

In the patch[5], I tried to change the default cinder's policy
to allow non admin users to execute migrate_volume_completion API.
But it was rejected by the cinder project ('-2' was voted).

In the patch[5], it was suggested to make the swap volume API admin only
on the Nova side.
But IMO, the swap volume function should be allowed to non admin users
because attaching a volume and detaching a volume can be performed
by non admin users.

If migrate_volume_completion is only allowed to admin users
by default on the Cinder side, attaching a new volume and
detaching an old volume should be performed on the Nova side
when swapping volumes.

If you have a good idea, please let me know it.

[1] Cinder volumes are stuck when non admin user executes nova swap volume API

[2] Cinder volume stuck in swap_volume

[3] Fix cinder volume stuck in swap_volume

[4] Fix swap_volume for case without migration

[5] Enable volume owners to execute migrate_volume_completion

Takashi Natsume
NTT Software Innovation Center
E-mail: natsume.takashi at lab.ntt.co.jp

More information about the OpenStack-dev mailing list