[openstack-dev] [ceilometer] Unable to get IPMI meter readings

Kapil kapil6442 at gmail.com
Wed Feb 24 22:18:58 UTC 2016


I discussed this problem with gordc on the telemetry IRC channel but I am
still facing issues.

I am running the ceilometer-agent-ipmi on the compute nodes, I changed
pipeline.yaml of the compute node to include the ipmi meters and resource
as "ipmi://localhost".

    - name: meter_ipmi
      interval: 60
          - ipmi://localhost
          - "hardware.ipmi.node*"
          - "hardware.ipmi*"
          - "hardware.degree*"
          - meter_sink

I have ipmitool installed on the compute nodes and restarted the ceilometer
services on compute and controller nodes. Yet, I am not receiving any ipmi
meters when I run "ceilometer meter-list". I also tried passing the
hypervisor IP address and the ipmi address I get when I run "ipmitool lan
print" to resources but to no avail.

Please help in this regard.

Kapil Agarwal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20160224/a1431dd0/attachment.html>

More information about the OpenStack-dev mailing list