[openstack-dev] [Tricircle] Naming convention

Shinobu Kinjo shinobu.kj at gmail.com
Fri Apr 1 23:40:00 UTC 2016


One of examples is:

"""
 tricircle/db/api.py
"""
authorize_quota_class_context(context, class_name):

# This could become:

auth_quota_class_ctx(ctx, class_name):

# If we put some comment for this, this also could become:

"""
  Function: Ensure a request has right permission to given the project.
  @ctx: user context
  @class: class name
"""
auth_quota_ctx(ctx, class):

Point here is, honestly not only name but also appropriate length of comment.
What do you think?

Cheers,
Shinobu


On Sat, Apr 2, 2016 at 8:20 AM, joehuang <joehuang at huawei.com> wrote:
> yes, good idea, could you point out or
>  report a bug which are not good naming.
>
> thanks.
>
> Sent from HUAWEI AnyOffice
> 发件人:shinobu.kj
> 收件人:openstack-dev,
> 时间:2016-04-02 06:21:50
> 主题:[openstack-dev] [Tricircle] Naming convention
>
> Hi Team,
>
> Probably it's worth thinking of naming convention for classes, methods
> or whatever we define in source codes.
>
> Some names are lengthy and there might be no consistency. At the
> moment it's fine. But once this project gets growing, situation would
> become chaotic and could cause bugs.
>
> What do you think?
>
> Cheers,
> Shinobu
>
> --
> Email:
> shinobu at linux.com
> GitHub:
> shinobu-x
> Blog:
> Life with Distributed Computational System based on OpenSource
>
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: OpenStack-dev-request at lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev



-- 
Email:
shinobu at linux.com
GitHub:
shinobu-x
Blog:
Life with Distributed Computational System based on OpenSource



More information about the OpenStack-dev mailing list