[openstack-dev] [devstack] pip wheel' requires the 'wheel' package

Timothy Swanson (tiswanso) tiswanso at cisco.com
Wed Mar 11 15:28:05 UTC 2015

I don’t have any solution just chiming in that I see the same error with devstack pulled from master on a new ubuntu trusty VM created last night.

'pip install —upgrade wheel’ indicates:
Requirement already up-to-date: wheel in /usr/local/lib/python2.7/dist-packages

Haven’t gotten it cleared up.



On Mar 2, 2015, at 2:11 AM, Smigiel, Dariusz <dariusz.smigiel at intel.com<mailto:dariusz.smigiel at intel.com>> wrote:

From: yuntong [mailto:yuntongjin at gmail.com]
Sent: Monday, March 2, 2015 7:35 AM
To: OpenStack Development Mailing List (not for usage questions)
Subject: [openstack-dev] [devstack] pip wheel' requires the 'wheel' package

I got an error when try to ./stack.sh as:
2015-03-02 05:58:20.692 | net.ipv4.ip_local_reserved_ports = 35357,35358
2015-03-02 05:58:20.959 | New python executable in tmp-venv-NoMO/bin/python
2015-03-02 05:58:22.056 | Installing setuptools, pip...done.
2015-03-02 05:58:22.581 | ERROR: 'pip wheel' requires the 'wheel' package. To fix this, run: pip install wheel

After pip install wheel, got same error.
In [2]: wheel.__path__
Out[2]: ['/usr/local/lib/python2.7/dist-packages/wheel']
In [5]: pip.__path__
Out[5]: ['/usr/local/lib/python2.7/dist-packages/pip']

$ which python

As above, the wheel can be imported successfully,
any hints ?


Did you try pip install –upgrade wheel ?
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request at lists.openstack.org<mailto:OpenStack-dev-request at lists.openstack.org>?subject:unsubscribe

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20150311/3897793c/attachment.html>

More information about the OpenStack-dev mailing list