[openstack-dev] [Cinder]Cinder services issues after add/remove/add driver

Eduard Matei eduard.matei at cloudfounders.com
Fri Jul 10 13:34:19 UTC 2015


Potential bug, but still investigating:
- configured a driver on cinder (besides lvm) - all ok
volume_driver = cinder.volume.drivers.openvstorage.OVSVolumeDriver
volume_backend_name = service1
vpool_name = service1
- removed it, restarted services - all ok (cinder service-list shows the
service as enabled and down)
- configured ANOTHER driver on cinder (similar to first) - new volumes
stuck in status "creating"

Tried "cinder service-disable", service showed "disabled" and "up" (?) then
later "disabled" and "down".
Tried changing in mysql (deleted = 1, then actually deleted).

Cinder-scheduler logs:
- Choosing NODE1 at service2#service2
- Flow 'volume_create_scheduler' (737556d0-a096-4639-899a-4bfd1c5bf166)
transitioned into state 'SUCCESS' from state 'RUNNING'
but the volume remains in status "creating", nothing is logged in c-vol on
any node

- 3 nodes setup, Devstack 2014.2.2, Ubuntu 14.04
- c-api, c-sch and c-vol running on all 3 nodes

Any help appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20150710/ebfa1969/attachment.html>

More information about the OpenStack-dev mailing list