[openstack-dev] Error starting designate (DNSaaS)

Jaime Fernández jjjaime at gmail.com
Mon Jul 6 09:06:12 UTC 2015

Finally, I got to install and start designate when moving to a trusty
Ubuntu image:

I did not succeed with precise64 (also Ubuntu):

On Thu, Jul 2, 2015 at 6:36 PM, Jaime Fernández <jjjaime at gmail.com> wrote:

> Thanks Tim for the info.
> I've tried the installation of designate using the recommended guide (
> http://docs.openstack.org/developer/designate/install/ubuntu-dev.html) in
> a vagrant with ubuntu (precise64 image).
> I've found a problem in the same step. However, now the error is different:
> $ designate-manage database sync
> No handlers could be found for logger "oslo_config.cfg"
> usage: designate [-h] [--config-dir DIR] [--config-file PATH] [--debug]
>                  [--log-config-append PATH] [--log-date-format DATE_FORMAT]
>                  [--log-dir LOG_DIR] [--log-file PATH] [--log-format
>                  [--nouse-syslog] [--nouse-syslog-rfc-format] [--noverbose]
>                  [--syslog-log-facility SYSLOG_LOG_FACILITY] [--use-syslog]
>                  [--use-syslog-rfc-format] [--verbose] [--version]
> [--nodebug]
>                  {powerdns} ...
> designate: error: argument category: invalid choice: 'database' (choose
> from 'powerdns')
> I've tried with master branch and even with stable/kilo branch with the
> same result.
> I've also noticed that master branch requires a custom installation of
> SQLAlchemy to avoid a version conflict:
> *pip install SQLAlchemy==0.9.9*
> I've contacted to #openstack-dns today and it looks like a dependency
> problem. However, all the dependencies were installed successfully. For me
> it's too hard to investigate the root of the problem. Tomorrow, I'll try to
> pursue this issue again in IRC.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20150706/147b0e36/attachment.html>

More information about the OpenStack-dev mailing list