[openstack-dev] Juno Compute RPC v3.33 Endpoint Error when the Controller is running rabbitMQ v3.4.2

Dan Smith dms at danplanet.com
Wed Jul 1 17:53:34 UTC 2015

> I have a three node Juno system running on Ubuntu 14.04. On the
> compute node I keep getting the following Endpoint does not support
> RPC version 3.33 to caller error when I launch a Nova instance. The
> Controller is running rabbitMQ v3.4.2. So I do not understand why the
> compute node thinks the endpoint does not support v3.33. I tried both
> rabbitMQ v3.3.3 and v3.5 on the compute node with the same result.

This message is referring to the nova compute RPC API version 3.33, not
the rabbit version.

> Data below. Any suggestions?

I imagine you've got different versions of nova on your nodes. Likely
your controller nodes are running something other (older) than the final
release of Juno, as 3.35 is what you should see if they were:


Even still, the compute nodes are older than 3.33 in some way, which
means you probably have two issues.

Since this is a deployment/operations question at this point, I think
it's probably better for one of the non-dev lists.


More information about the OpenStack-dev mailing list