[openstack-dev] [Openstack][infra] Zuul-Merger Error in CI

Asselin, Ramy ramy.asselin at hp.com
Tue Jan 27 15:34:43 UTC 2015

FYI, it wasn’t a change to my repo, but to openstack upstream that solved the 12.04 --> 14.04 issue: https://review.openstack.org/#/c/141518/
So this will help anyone using the Openstack-Infra zuul puppet modules!

From: Punith S [mailto:punith.s at cloudbyte.com]
Sent: Tuesday, January 27, 2015 4:32 AM
To: openstack-infra at lists.openstack.org; OpenStack Development Mailing List (not for usage questions)
Cc: Asselin, Ramy
Subject: Re: [Openstack][infra] Zuul-Merger Error in CI

Hi the merge fail error that we reported in ubuntu 12.04 has been solved in the new ubuntu 14.04 CI master setup.

many thanks to ramy on the update of the repo :) https://github.com/rasselin/os-ext-testing


On Thu, Jan 8, 2015 at 7:16 PM, Punith S <punith.s at cloudbyte.com<mailto:punith.s at cloudbyte.com>> wrote:

i'm running CI for openstack cinder patches, when zuul reads a new patch from gerrit, it tries to merge the patch to it's own cinder repo @/var/lib/zuul/git/openstack/cinder

and returns the comment to gerrit saying

[cid:image001.jpg at 01D03A03.B7884B60]

hence it is failing to issue the dsvm-tempest-job in jenkins via gearman !!!
the zuul/merger-debug log sanpshot

2015-01-08 19:03:43,320 DEBUG zuul.MergeServer: Got merge job.
2015-01-08 19:03:43,321 DEBUG zuul.Merger: Merging for change 145778,1.
2015-01-08 19:03:43,321 DEBUG zuul.Merger: Processing refspec refs/changes/78/145778/1 for project openstack/cinder / master ref Zbd4a4ad6ff3741c68ce382afa6d8df84
2015-01-08 19:03:43,383 DEBUG zuul.Merger: Unable to find commit for ref master/Zbd4a4ad6ff3741c68ce382afa6d8df84
2015-01-08 19:03:43,384 DEBUG zuul.Merger: No base commit found for (u'openstack/cinder', u'master')
2015-01-08 19:03:43,384 DEBUG zuul.Repo: Resetting repository /var/lib/zuul/git/openstack/cinder
2015-01-08 19:03:43,385 DEBUG zuul.Repo: Updating repository /var/lib/zuul/git/openstack/cinder
2015-01-08 19:03:54,507 DEBUG zuul.Repo: Checking out 5993660498f44e96b0f35ccc0f4d4a4c7b430363
2015-01-08 19:04:02,685 ERROR zuul.Merger: Exception while merging a change:
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/zuul/merger/merger.py", line 234, in _mergeChange
    commit = repo.merge(item['refspec'], 'resolve')
  File "/usr/local/lib/python2.7/dist-packages/zuul/merger/merger.py", line 132, in merge
  File "/usr/local/lib/python2.7/dist-packages/zuul/merger/merger.py", line 145, in fetch
  File "/usr/local/lib/python2.7/dist-packages/git/remote.py", line 598, in fetch
    return self._get_fetch_info_from_stderr(proc, progress or RemoteProgress())
  File "/usr/local/lib/python2.7/dist-packages/git/remote.py", line 540, in _get_fetch_info_from_stderr
    for err_line, fetch_line in zip(fetch_info_lines, fetch_head_info))
  File "/usr/local/lib/python2.7/dist-packages/git/remote.py", line 540, in <genexpr>
    for err_line, fetch_line in zip(fetch_info_lines, fetch_head_info))
  File "/usr/local/lib/python2.7/dist-packages/git/remote.py", line 252, in _from_line
    raise ValueError("Failed to parse line: %r" % line)
ValueError: Failed to parse line: 'Total 7 (delta 5), reused 7 (delta 5)'

is this a problem of python git ?

i'm using ubuntu 12.04 and git 1.7

thanks in advance

punith s


punith s
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20150127/efcd3849/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.jpg
Type: image/jpeg
Size: 4704 bytes
Desc: image001.jpg
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20150127/efcd3849/attachment.jpg>

More information about the OpenStack-dev mailing list