[openstack-dev] [Horizon] Separate horizon and openstack_dashboard

Wood, Matthew David (HP Cloud - Horizon) matt.wood at hp.com
Fri Nov 14 15:46:36 UTC 2014

On 11/14/14, 4:24 AM, "Jaromir Coufal" <jcoufal at redhat.com> wrote:

>On 11/11/14 09:30, Jiri Tomasek wrote:
>> On 11/10/2014 12:19 PM, Matthias Runge wrote:
>>> On Thu, Oct 30, 2014 at 01:13:48PM +0100, Matthias Runge wrote:
>>>> Hi,
>>>> tl;dr: how to progreed in separating horizon and openstack_dashboard
>>>> About a year ago now we agreed, it makes sense to separate horizon and
>>>> openstack_dashboard.
>>> At the past summit, we discussed this again. Currently, our repo
>>> contains two directories: horizon and openstack_dashboard, they both
>>> will need new names.
>>> We discussed a renaming in the past; the former consensus was:
>>> rename horizon to horizon_lib and
>>> rename openstack_dashboard to horizon.
>>> IMHO that doesn't make any sense and will confuse people a lot. I
>>> wouldn't object to rename horizon to horizon_lib, although any other
>>> name, e.g django-horizon should be fine as well.
>>> openstack_dashboard is our official name; people from outside refer to
>>> the Dashboard as Horizon, why not rename to openstack_horizon here?
>It is official name, but I disagree that people refer more to Dashboard
>than to Horizon. People mostly talk about Horizon and when they say
>Horizon they refer to the UI. Dashboard is not much used outside Horizon
>community and is a bit confusing (overloaded).
>Small example - when you want to add the general overview page - the
>actual dashboard, that should be the *dashboard* name how it should be
>used. Otherwise we are adding _Dashboard_ view into Project's
>_dashboard_ into OpenStack _Dashboard_ project. That's what I really see
>confusing :)
>My opinion and preference:
>* horizon_lib (framework) + horizon (UI)

I agree with both the concept behind these names and the name selections
given here.  People don¹t think of Nova as the framework, nor Neutron as
the framework.  That¹s the server/service that we make rest calls against.
 I like:

(horizon_lib or horizon_framework) and horizon
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5489 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20141114/acbf0c60/attachment.bin>

More information about the OpenStack-dev mailing list