[openstack-dev] [oslo] dropping namespace packages

Donald Stufft donald at stufft.io
Wed Nov 12 20:37:10 UTC 2014

> On Nov 12, 2014, at 3:32 PM, Doug Hellmann <doug at doughellmann.com> wrote:
> We rather quickly came to consensus at the summit that we should drop the use of namespace packages in Oslo libraries [1]. As far as I could tell, everyone was happy with my proposed approach [2] of moving the code from oslo.foo to oslo_foo and then creating a backwards-compatibility shim in oslo.foo that imports public symbols from oslo_foo. We also agreed that we would not rename existing libraries, and we would continue to use the same naming convention for new libraries. So the distribution and git repository both will be called “oslo.foo” and the import statement would look like “from oslo_foo import bar”.
> Doug
> [1] https://etherpad.openstack.org/p/kilo-oslo-namespace-packages
> [2] https://review.openstack.org/128759

+1 for whatever my vote is worth :)

Donald Stufft
PGP: 7C6B 7C5D 5E2B 6356 A926 F04F 6E3C BCE9 3372 DCFA

More information about the OpenStack-dev mailing list