[openstack-dev] [nova] [bug?] live migration fails with boot-from-volume

Day, Phil philip.day at hp.com
Sat Mar 8 09:43:30 UTC 2014

I guess that would depend on whether the flavour has any ephemeral storage in addition to the boot volume.

The block migration should work in this case,  have you tried that.

Sent from Samsung Mobile

-------- Original message --------
From: Chris Friesen
Date:08/03/2014 06:16 (GMT+00:00)
To: openstack-dev at lists.openstack.org
Subject: [openstack-dev] [nova] [bug?] live migration fails with boot-from-volume


I was just testing the current icehouse code and came across some
behaviour that looked suspicious.

I have two nodes, an all-in-one and a compute node.  I was not using
shared instance storage.

I created a volume from an image and then booted an instance from the
volume.  Once the image was up and running I tried to do a "nova
live-migration <instance>" and got the following error:

cfriesen at controller:/opt/stack/nova/nova/compute$ nova live-migration
ERROR: controller is not on shared storage: Live migration can not be
used without shared storage. (HTTP 400) (Request-ID:

Shouldn't booting from volume count as a form of shared storage?


OpenStack-dev mailing list
OpenStack-dev at lists.openstack.org

More information about the OpenStack-dev mailing list