[openstack-dev] [Neutron] Debugger issues with service plugins

Brandon Logan brandon.logan at RACKSPACE.COM
Thu Mar 6 20:10:38 UTC 2014

While learning the code base of neutron and the extensions better, I've been attempting to get a debugger working with Neutron with service plugins (such as l3router and lbaas).  When running the debugger without service plugins everything works well.  When running the debugger with the service plugins, the code almost always seems to hang in the __init__ method of the loading service plugin class.  However, just by brute force restarting the debugging it will sometimes work as expected.  It is very inconsistent in that it does work occassionally, and when it hangs it is not always at the same place.  I have noticed that it does hang mostly on when either 1) the neutron.db.api.register_models() method is called or 2) setting up rpc code is executed.

Obviously, this all works when just running code with service plugins but without a debugger.

I've tried it with pdb and pydev debugger.  It happens with both.

I changed eventlet.monkey_patch() line to eventlet.monkey_patch(os=False, thread=False) in the neutron.server module.

I was wondering if anyone else has tried this and overcome it.  Please let me know if so.

Oh, and I'm also doing this on a single host devstack install.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20140306/2dbe0e08/attachment.html>

More information about the OpenStack-dev mailing list