[openstack-dev] [devstack][multi-node installation]Compute node can't connnected to qpid and mysql.

Li, Chen chen.li at intel.com
Thu Jun 5 08:42:09 UTC 2014

Hi list,

I'm trying to install openstack ml2 neutron ml2 plugin devstack on 2 nodes with CentOS.

Basically, I have followed http://devstack.org/guides/multinode-lab.html.
That is really helpful.

Things looks well on controller node.
But, on the compute node, I get many issues.

This is my local.conf on compute node:

After run "./stack.sh", I get:

So, I run "./rejoin-stack.sh".
Three services has been started: 1$ q-agt 2$ n-cpu 3-$ c-vol

But, neutron-agent and nova-compute is complains about "Unable to connect to AMQP server".
And cinder-volume complains about "SQL connection failed"

Because services on controller node works well, so I first thought it is caused by iptables.
but after I run:
sudo iptables -I INPUT 1 -p tcp --dport 5672
sudo iptables -I INPUT 1 -p tcp --dport 3306
on controller node.
The issue is still there.

Anyone know why this happened ??

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20140605/5a267a90/attachment.html>

More information about the OpenStack-dev mailing list