[openstack-dev] [Neutron][LBaaS] Failure when trying to rebase to latest v2 patches

Brandon Logan brandon.logan at RACKSPACE.COM
Mon Aug 18 03:22:38 UTC 2014

Hi Vijay,
Are you trying to rebase by pulling down the new changes and rebasing your branch on top of that?  That'll usually end up wrong because of commit hashes.  Have you tried using the rebase button gerrit provides?  Let me know how exactly you're trying to rebase if you've already tried the gerrit rebase button or if you'd like to know how to do it by rebasing locally. 
I'm going to add more details to that GerritWorkflow wiki page.  It's lacking on dependency chains and how to do rebases, cherry-picks, etc without accidentally pushing more patch sets to dependent reviews.  I've been meaning to do I've just been lazy about doing that.

From: Vijay Venkatachalam [Vijay.Venkatachalam at citrix.com]
Sent: Sunday, August 17, 2014 9:19 PM
To: OpenStack Development Mailing List (not for usage questions)
Subject: [openstack-dev] [Neutron][LBaaS] Failure when trying to rebase to latest v2 patches

Hi Brandon,

I am trying to rebase Netscaler driver to the latest v2 patches as mentioned in https://wiki.openstack.org/wiki/GerritWorkflow
But it failed during review submit

It failed with the following error
remote: Processing changes: refs: 1, done
To ssh://vijayvenkatachalam@review.openstack.org:29418/openstack/neutron.git
 ! [remote rejected] HEAD -> refs/publish/master/bp/netscaler-lbass-v2-driver (squash commits first)
error: failed to push some refs to 'ssh://vijayvenkatachalam@review.openstack.org:29418/openstack/neutron.git'

Any clues on how to proceed?

Vijay V.
OpenStack-dev mailing list
OpenStack-dev at lists.openstack.org

More information about the OpenStack-dev mailing list