<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Tue, Jan 6, 2015 at 8:55 AM, Jay Pipes <span dir="ltr"><<a href="mailto:jaypipes@gmail.com" target="_blank">jaypipes@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On 01/02/2015 03:10 PM, Dean Troyer wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I suppose first of all, does there remain a need/desire to add these for<br>
Image API v1?<br>
</blockquote>
<br></span>
Yes. There's many shops that still use the v1 Glance API. And, Nova itself, has little current support for v2 Glance API.</blockquote><div><br></div><div>Fortunately Nova doesn't use a CLI to do that... ;) I'll take another look at the differences...I really don't want for the user to need to know which API version is being used if at all possible.</div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
--share <project> - add <project> to the shared-with list for this image<br>
--no-share <project> - remove <project> from the shared-with list<br>
('image set' only)<br>
</blockquote>
<br></span>
Is image set equal to image update in v1 parlance?</blockquote><div><br></div><div>The 'set' verb is totally an artifact of OSC for changing attributes of an existing resource. </div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Both --share and --no-share options may be repeated, much as the<br>
--properties option works today.<br>
</blockquote>
<br></span>
I would prefer --share and --unshare or --add-member and --remove-member. Typically, --no- prefix on a CLI option means to disable a boolean option.</blockquote><div><br></div><div>I'll buy that. Or Kevin's suggestion of --grant/-revoke which I still need to noodle over a bit.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
In addition, the 'receiving' project must ACK the sharing, which would<br>
be an added option to 'image set':<br>
<br>
--share ack - the magic value 'ACK' (case insensitive) signifies the<br>
acceptance of a shared image by the 'receiving' project<br>
</blockquote>
<br></span>
IMHO. Would have been a bit nicer to have something like this:<br>
<br>
glance image member [confirm|decline] <IMAGE_ID> [<PROJECT_ID>]</blockquote><div><br></div><div>OK, I'll re-think this...magic values stink...</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
A couple of new options are added to 'image list' to select shared images:<br>
<br>
--shared - filter on shared images only<br>
--project <project> - filter on <project> (this may imply --shared?)<br>
</blockquote>
<br></span>
Or:<br>
<br>
--shared-with=<project></blockquote><div><br></div><div>I like that...</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Some of the questions I have:<br>
<br>
* Is --no-share the correct antonym of --share? --unshare maybe? We<br>
have a pattern of using regular English words were possible<br>
(enable|disable) rather than the GNU style of prepending 'no-' to<br>
options, but that is my current backup.<br>
</blockquote>
<br></span>
Prefer --unshare to --no-share, but prefer --add-member/--remove-member to either :)</blockquote><div><br></div><div>Honestly I'm trying very hard to avoid using the word 'member', it's meaningless to me in this usage.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
* Do we need an 'un-ACK' option for a 'receiving' project to remove the<br>
shared image from their list without requiring the owner project to do<br>
so? Is this even possible in the Image v2 API?<br>
</blockquote>
<br></span>
See suggestion above:<br>
<br>
glance image member decline <IMAGE_ID> [<PROJECT_ID>]<br></blockquote><div><br></div><div>So decline is both a NAK and an un-ACK (after the image has already been ACK-ed). Make sense? I can live with that if so, just wondering if that will be obvious to other users.</div></div><div><br></div><div>dt</div><div><br></div>-- <br><div class="gmail_signature"><br>Dean Troyer<br><a href="mailto:dtroyer@gmail.com">dtroyer@gmail.com</a><br></div>
</div></div>