<div dir="ltr"><div class="gmail_quote"><div dir="ltr">tl;dr</div><div>+1 consistent names<br></div><div>I would make the names mirror the API</div><div>... because the Operator setting them knows the API, not the code</div><div>Ignore the crazy names in Nova, I certainly hate them</div><div><br></div><div><br></div><div>Lance Bragstad <<a href="mailto:lbragstad@gmail.com">lbragstad@gmail.com</a>> wrote:<br></div><div>> I'm curious if anyone has context on the "os-" part of the format?<br></div><div><br></div><div>My memory of the Nova policy mess...</div><div>* Nova's policy rules traditionally followed the patterns of the code<br></div><div>** Yes, horrible, but it happened.</div><div>* The code used to have the OpenStack API and the EC2 API, hence the "os"</div><div>* API used to expand with extensions, so the policy name is often based on extensions</div><div>** note most of the extension code has now gone, including lots of related policies</div><div>* Policy in code was focused on getting us to a place where we could rename policy</div><div>** Whoop whoop by the way, it feels like we are really close to something sensible now!</div><div><br></div><div dir="ltr">Lance Bragstad <<a href="mailto:lbragstad@gmail.com">lbragstad@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div>Thoughts on using create, list, update, and delete as opposed to post, get, put, patch, and delete in the naming convention?</div></div></div></div></blockquote><div><br></div><div>I could go either way as I think about "list servers" in the API.</div><div>But my preference is for the URL stub and POST, GET, etc.</div><div><br></div><div>¬†On Sun, Sep 16, 2018 at 9:47 PM Lance Bragstad <<a href="mailto:lbragstad@gmail.com" target="_blank">lbragstad@gmail.com</a>> wrote:</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">If we consider dropping "os", should we entertain dropping "api", too? Do we have a good reason to keep "api"?<div>I wouldn't be opposed to simple service types (e.g "compute" or "loadbalancer").</div></div></blockquote></div></blockquote><div><br></div><div>+1</div><div>The API is known as "compute" in api-ref, so the policy should be for "compute", etc.</div><div><br></div><div>From: Lance Bragstad <<a href="mailto:lbragstad@gmail.com" rel="noreferrer" target="_blank">lbragstad@gmail.com</a>></div><div>> The topic of having consistent policy names has popped up a few times this week.<br></div><div><br></div><div>I would love to have this nailed down before we go through all the policy rules again. In my head I hope in Nova we can go through each policy rule and do the following:</div><div><br></div><div>* move to new consistent policy name, deprecate existing name</div><div>* hardcode scope check to project, system or user</div><div>** (user, yes... keypairs, yuck, but its how they work)</div><div>** deprecate in rule scope checks, which are largely bogus in Nova anyway</div><div>* make read/write/admin distinction</div><div>** therefore adding the "noop" role, amount other things</div><div><br></div><div>Thanks,</div><div>John</div></div></div>