<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Windows-1252">
</head>
<body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; color: rgb(0, 0, 0); font-size: 14px; font-family: Calibri, sans-serif;">
<div>Geo,</div>
<div><br>
</div>
<div>Sorry for not getting back sooner.  Was out sick.  Can you post the output of 'ovs-vsctl show'?  I didnít see a br-ex interface in your ifconfig output.</div>
<div><br>
</div>
<div>Thx,</div>
<div>britt</div>
<div><br>
</div>
<div><br>
</div>
<span id="OLK_SRC_BODY_SECTION">
<div style="font-family:Calibri; font-size:11pt; text-align:left; color:black; BORDER-BOTTOM: medium none; BORDER-LEFT: medium none; PADDING-BOTTOM: 0in; PADDING-LEFT: 0in; PADDING-RIGHT: 0in; BORDER-TOP: #b5c4df 1pt solid; BORDER-RIGHT: medium none; PADDING-TOP: 3pt">
<span style="font-weight:bold">From: </span>Geo Varghese <<a href="mailto:gvarghese@aqorn.com">gvarghese@aqorn.com</a>><br>
<span style="font-weight:bold">Date: </span>Friday, November 21, 2014 at 1:39 PM<br>
<span style="font-weight:bold">To: </span>Britt Houser <<a href="mailto:bhouser@cisco.com">bhouser@cisco.com</a>><br>
<span style="font-weight:bold">Cc: </span>"<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>" <<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>>, "<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>"
 <<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>><br>
<span style="font-weight:bold">Subject: </span>Re: [Openstack-operators] While adding external bridge connection lost to the network node<br>
</div>
<div><br>
</div>
<div>
<div>
<div dir="ltr">Britt,
<div><br>
</div>
<div>Just tried it but network restart failed if I add these lines. Also IP not assigned to bridge when controller restarted.</div>
<div><br>
</div>
<div>When try to do following command after this change</div>
<div><br>
</div>
<div>ifdown eth0</div>
<div><br>
</div>
<div>Show error in following line  in /etc/network/interfaces</div>
<div><br>
</div>
<div>iface br-ex inet static<br>
</div>
<div><br>
</div>
<div>Thanks again for your support.<br>
</div>
<div class="gmail_extra"><br>
<div class="gmail_quote">On Fri, Nov 21, 2014 at 6:05 PM, Britt Houser (bhouser) <span dir="ltr">
<<a href="mailto:bhouser@cisco.com" target="_blank">bhouser@cisco.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
The br-ex config looks right, but you don't want eth0 to DHCP for an<br>
address anymore.  Once its attached to br-ex, its an L2-only interface<br>
(similar to switchport on cisco switch).  I think you want something like<br>
this for eth0:<br>
<br>
auto eth0<br>
iface eth0 inet manual<br>
  pre-up ifconfig $IFACE up<br>
  post-down ifconfig $IFACE down<br>
<span class=""><br>
<br>
Thx,<br>
britt<br>
<br>
From:  Geo Varghese <<a href="mailto:gvarghese@aqorn.com">gvarghese@aqorn.com</a>><br>
</span>Date:  Friday, November 21, 2014 at 7:22 AM<br>
<span class="">To:  Britt Houser <<a href="mailto:bhouser@cisco.com">bhouser@cisco.com</a>><br>
Cc:  "<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>" <<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>>,<br>
"<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>"<br>
<<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>><br>
Subject:  Re: [Openstack-operators] While adding external bridge<br>
connection lost to the network node<br>
<br>
<br>
</span><span class="">Thanks Britt.<br>
<br>
<br>
You mean like this right?<br>
<br>
cat /etc/network/interfaces<br>
=========================<br>
# The loopback network interface<br>
auto lo<br>
iface lo inet loopback<br>
<br>
# The primary network interface<br>
auto eth0<br>
iface eth0 inet dhcp<br>
<br>
# The external network interface<br>
auto br-ex<br>
iface br-ex inet static<br>
       address 192.168.122.54<br>
       netmask 255.255.255.0<br>
       gateway 192.168.122.1<br>
       dns-nameservers 8.8.8.8 8.8.4.4<br>
==========================================================<br>
<br>
<br>
<br>
On Fri, Nov 21, 2014 at 5:48 PM, Britt Houser (bhouser)<br>
<<a href="mailto:bhouser@cisco.com">bhouser@cisco.com</a>> wrote:<br>
<br>
Correct.  You need to updated your /etc/interfaces file so that the<br>
</span><a href="http://192.168.122.54/24" target="_blank">192.168.122.54/24</a> <<a href="http://192.168.122.54/24" target="_blank">http://192.168.122.54/24</a>> address gets assigned to<br>
<div class="">
<div class="h5">br-ex instead of eth0.<br>
<br>
From: Geo Varghese <<a href="mailto:gvarghese@aqorn.com">gvarghese@aqorn.com</a>><br>
Date: Friday, November 21, 2014 at 7:16 AM<br>
To: Britt Houser <<a href="mailto:bhouser@cisco.com">bhouser@cisco.com</a>><br>
Cc: "<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>" <<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>>,<br>
"<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>"<br>
 <<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>><br>
Subject: Re: [Openstack-operators] While adding external bridge connection<br>
lost to the network node<br>
<br>
<br>
Hi Britt,<br>
<br>
Thanks for the answer.<br>
<br>
I am using Virtual machine(KVM) for openstack installation. Its a single<br>
node installation.<br>
<br>
<br>
Now i can create instance from openstack dahboard and and can login in to<br>
the instance from dashboard konsole.<br>
<br>
But i couln't connect to instance from controller node.<br>
<br>
Also i couldn't have connection between instances.<br>
<br>
Ifconfig output from openstack installation node<br>
=======================<br>
root@ubuntu:/home/geo# ifconfig<br>
br-int    Link encap:Ethernet  HWaddr 26:73:95:7a:c5:4e<br>
          inet6 addr: fe80::ec9d:9aff:fe2f:66ab/64 Scope:Link<br>
          UP BROADCAST RUNNING  MTU:1500  Metric:1<br>
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0<br>
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:0<br>
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)<br>
<br>
br-tun    Link encap:Ethernet  HWaddr 0e:af:b2:8e:89:44<br>
          inet6 addr: fe80::c89f:cfff:fe74:712/64 Scope:Link<br>
          UP BROADCAST RUNNING  MTU:1500  Metric:1<br>
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0<br>
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:0<br>
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)<br>
<br>
eth0      Link encap:Ethernet  HWaddr 52:54:00:d6:4c:4f<br>
          inet addr:192.168.122.54  Bcast:192.168.122.255<br>
Mask:255.255.255.0<br>
          inet6 addr: fe80::5054:ff:fed6:4c4f/64 Scope:Link<br>
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1<br>
          RX packets:162 errors:0 dropped:3 overruns:0 frame:0<br>
          TX packets:100 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:1000<br>
          RX bytes:16187 (16.1 KB)  TX bytes:13445 (13.4 KB)<br>
<br>
lo        Link encap:Local Loopback<br>
          inet addr:127.0.0.1  Mask:255.0.0.0<br>
          inet6 addr: ::1/128 Scope:Host<br>
          UP LOOPBACK RUNNING  MTU:65536  Metric:1<br>
          RX packets:737 errors:0 dropped:0 overruns:0 frame:0<br>
          TX packets:737 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:0<br>
          RX bytes:104803 (104.8 KB)  TX bytes:104803 (104.8 KB)<br>
<br>
tap561bdedf-3e Link encap:Ethernet  HWaddr 42:c5:72:1c:3b:99<br>
          inet6 addr: fe80::40c5:72ff:fe1c:3b99/64 Scope:Link<br>
          UP BROADCAST RUNNING  MTU:1500  Metric:1<br>
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0<br>
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:0<br>
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)<br>
<br>
tapde436ec7-3b Link encap:Ethernet  HWaddr b6:09:88:dc:f7:5a<br>
          inet6 addr: fe80::b409:88ff:fedc:f75a/64 Scope:Link<br>
          UP BROADCAST RUNNING  MTU:1500  Metric:1<br>
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0<br>
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:0<br>
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)<br>
======================================<br>
<br>
<br>
Same eth0 i have used to add br-ex, you mean thats the issue right?<br>
<br>
<br>
On Fri, Nov 21, 2014 at 5:31 PM, Britt Houser (bhouser)<br>
<<a href="mailto:bhouser@cisco.com">bhouser@cisco.com</a>> wrote:<br>
<br>
Was the interface you added to br-ex the same interface to which you<br>
connected to the box?  If so, this is expected.  When you add an interface<br>
to the bridge you lose IP connectivity to that interface.  The IP address<br>
which which was assigned to the interface<br>
 now needs to be assigned to the br-ex bridge, and then you'll have<br>
connectivity once again.<br>
<br>
Thx,<br>
britt<br>
<br>
From: Geo Varghese <<a href="mailto:gvarghese@aqorn.com">gvarghese@aqorn.com</a>><br>
Date: Friday, November 21, 2014 at 1:39 AM<br>
To: "<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>" <<a href="mailto:openstack@lists.openstack.org">openstack@lists.openstack.org</a>>,<br>
"<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>"<br>
 <<a href="mailto:openstack-operators@lists.openstack.org">openstack-operators@lists.openstack.org</a>><br>
Subject: [Openstack-operators] While adding external bridge connection<br>
lost to the network node<br>
<br>
<br>
Hi Team,<br>
<br>
While adding external bridge connection lost to the network node from<br>
other nodes. we couldn't ssh to network node after creating bridge.<br>
<br>
If we do below steps of following link<br>
<br>
<a href="http://docs.openstack.org/icehouse/install-guide/install/apt/content/neutro
n-ml2-network-node.html" target="_blank">http://docs.openstack.org/icehouse/install-guide/install/apt/content/neutro<br>
n-ml2-network-node.html</a><br>
<br>
===========================================<br>
3) Add the external bridge:<br>
<br>
# ovs-vsctl add-br br-ex<br>
<br>
4) Add a port to the external bridge that connects to the physical<br>
external network interface:<br>
<br>
Replace INTERFACE_NAME with the actual interface name. For example, eth2<br>
or ens256.<br>
<br>
# ovs-vsctl add-port br-ex INTERFACE_NAME<br>
=============================================<br>
<br>
External connection to network node fails. Then we couldn't connect to<br>
network node from other machines.<br>
<br>
Any one faced this issue?<br>
<br>
Please help us to fix this issue.<br>
<br>
<br>
<br>
<br>
</div>
</div>
<div class="">
<div class="h5">--<br>
Regards,<br>
Geo Varghese<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
--<br>
--<br>
Regards,<br>
Geo Varghese<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
--<br>
--<br>
Regards,<br>
Geo Varghese<br>
<br>
</div>
</div>
</blockquote>
</div>
<br>
<br clear="all">
<br>
-- <br>
<div class="gmail_signature">
<div dir="ltr">--
<div>Regards,</div>
<div>Geo Varghese</div>
</div>
</div>
</div>
</div>
</div>
</div>
</span>
</body>
</html>