<div dir="ltr"><div class="gmail_default" style="font-family:courier new,monospace">Thanks for the information. I just tried doing it with a VM with only 2 cores and it has been working fine. So it seems that it may be specific to the number of cores that are involved. I'll try with 4 to see if that works ok. ¬†Thankfully we don't have many 8-core machines but we still have the need to migrate them for maintenance.</div><div class="gmail_default" style="font-family:courier new,monospace"><br></div><div class="gmail_default" style="font-family:courier new,monospace">Does this core-specific information help to figure out what the problem is?</div><div class="gmail_default" style="font-family:courier new,monospace"><br></div><div class="gmail_default" style="font-family:courier new,monospace"><br></div><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Sep 12, 2014 at 2:31 PM, Jonathan Proulx <span dir="ltr"><<a href="mailto:jon@jonproulx.com" target="_blank">jon@jonproulx.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On Fri, Sep 12, 2014 at 1:44 PM, Stephen Cousins<br>
<<a href="mailto:steve.cousins@maine.edu">steve.cousins@maine.edu</a>> wrote:<br>
<br>
> Does anyone live-migrate VM's successfully when volumes are attached?<br>
<br>
</span>My setup is significantly different so probably not terribly helpful,<br>
but to answer the question I did do live migrations with Volumes<br>
attached on my Grizzly cloud (since upgraded to Icehouse).¬† We don't<br>
have shared storage for the ephemeral disks and our Volumes are iSCSI<br>
attached (from an equallogic san), so something like:<br>
<br>
nova live-migration --block-migrate <server> [<host>]<br>
<br>
I wouldn't say it was 100% but the volume piece wasn't a problem. Well<br>
once I figured out in my case I needed to flip some bits on the SAN<br>
side to allow multiple logins to the same target as source and<br>
destination are both connected during a migration, but I wouldn't<br>
expect that to be an issue with NFS<br>
<br>
-Jon<br>
</blockquote></div><br><br clear="all"><div><br></div>
</div></div>