[Openstack-operators] [openstack-dev] [all] Consistent policy names
sean.mcginnis at gmx.com
Fri Sep 28 14:33:15 UTC 2018
> On Fri, Sep 28, 2018 at 8:48 AM Lance Bragstad <lbragstad at gmail.com> wrote:
> > Bumping this thread again and proposing two conventions based on the
> > discussion here. I propose we decide on one of the two following
> > conventions:
> > *<service-type>:<action>:<resource>*
> > or
> > *<service-type>:<action>_<resource>*
> > Where <service-type> is the corresponding service type of the project ,
> > and <action> is either create, get, list, update, or delete. I think
> > decoupling the method from the policy name should aid in consistency,
> > regardless of the underlying implementation. The HTTP method specifics can
> > still be relayed using oslo.policy's DocumentedRuleDefault object .
> > I think the plurality of the resource should default to what makes sense
> > for the operation being carried out (e.g., list:foobars, create:foobar).
> > I don't mind the first one because it's clear about what the delimiter is
> > and it doesn't look weird when projects have something like:
> > <service-type>:<action>:<subaction>:<resource>
My initial preference was the second format, but you make a good point here
about potential subactions. Either is fine with me - the main thing I would
love to see is consistency in format. But based on this part, I vote for option
> > If folks are ok with this, I can start working on some documentation that
> > explains the motivation for this. Afterward, we can figure out how we want
> > to track this work.
+1 thanks for working on this!
More information about the OpenStack-operators