[Openstack-operators] [Openstack] Recovering from full outage

Torin Woltjer torin.woltjer at granddial.com
Thu Jul 12 12:20:32 UTC 2018

The neutron-metadata-agent service is running, the the agent is alive, and it is listening on port 8775. However, new instances still do not get any information like hostname or keypair. If I run `curl` from the compute nodes, I do get a response. The metadata agent is running, listening, and accessible from the compute nodes; and it worked previously.

I'm stumped.

Torin Woltjer
Grand Dial Communications - A ZK Tech Inc. Company
616.776.1066 ext. 2006

From: அருண் குமார் (Arun Kumar) <thangam.arunx at gmail.com>
Sent: 7/12/18 12:01 AM
To: torin.woltjer at granddial.com
Cc: "openstack at lists.openstack.org" <openstack at lists.openstack.org>, openstack-operators at lists.openstack.org
Subject: Re: [Openstack-operators] [Openstack] Recovering from full outage
Hi Torin,

If I run `ip netns exec qrouter netstat -lnp` or `ip netns exec qdhcp netstat -lnp` on the controller, should I see anything listening on the metadata port (8775)? When I run these commands I don't see that listening, but I have no example of a working system to check against. Can anybody verify this?

Either on qrouter/qdhcp namespaces, you won't see port 8775, instead check whether meta-data service is running on the neutron controller node(s) and listening on port 8775? Aslo, you can verify metadata and neturon services using following commands

service neutron-metadata-agent status neutron agent-list  netstat -ntplua | grep :8775

Thanks & Regards

நுட்பம் நம்மொழியில் தழைக்கச் செய்வோம்

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20180712/959f608c/attachment.html>

More information about the OpenStack-operators mailing list