[Openstack-operators] [cinder] [nova] Inconsistency

Sinan Polat sinan at turka.nl
Wed Sep 13 20:15:17 UTC 2017



I am trying to live-migrate an instace to another compute, but it is
failing. The nova log shows me about missing volumes.


When I browse to the instance via Horizon Dashboard, the instance is

No volumes attached. (Which is strange, it should have 2 volumes attached)


When I browse to Volumes, there are 2 volumes that are shown as attached to
the instance. Which is correct.


When I run the following command, it shows 9 volumes attached (strange,
Horizon shows no volumes attached):

nova show <instance id>


The first 2 volumes are correct, they should be attached, but the other 7
volumes are not attached and should not be shown.


When I run a "cinder show <volume-id>" against the 7 volumes, the volumes
cannot be found (except for the first 2 volumes, which should be attached).


I am running Openstack Kilo.


As first, I would like to migrate the instance to another compute. How can I
accomplish this?

As second, how did this happen and how to prevent such Inconsistencies in





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20170913/d8a9ad3b/attachment.html>

More information about the OpenStack-operators mailing list