[Openstack-operators] Virtual Instance can't obtain IP address (OpenStack Havana)

David Magda dmagda at ee.ryerson.ca
Wed Jan 29 19:17:27 UTC 2014

On Wed, January 29, 2014 13:01, Alvise Dorigo wrote:

> I issued that command on my eth2 NIC which is connected to the
> data-network
> [root at network ~]# ethtool -k eth2 | grep offload
> tcp-segmentation-offload: on
> udp-fragmentation-offload: off
> generic-segmentation-offload: on
> generic-receive-offload: off
> large-receive-offload: off
> Did I do correctly ?
> The offload is on. Should I change it ? how ?

According to this "cookbook", all offloading should (?) be disabled:


The GRO worked for us solving the DHCP issue. But you may be having
another problem that is causing the same sympton.

>> We recently solved this problem at $WORK by disabling GRO on our network
>> node.
>> The other issue we've come across that may be related is MTUs: since
>> Open vSwitch 1.9+ got rid of Path MTU Discovery, you may need to adjust
>> MTUs:
>>  http://techbackground.blogspot.ca/2013/06/path-mtu-discovery-and-gre.html
> In that article they talk about a GRE setup, but I choosed local
> (CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=local). Can I use that guide
> anyway ?

I don't know.

More information about the OpenStack-operators mailing list