python_requires >= 3.8 during Yoga

Jeremy Stanley fungi at
Wed Dec 1 18:24:31 UTC 2021

On 2021-12-01 10:31:58 -0700 (-0700), Alex Schultz wrote:
> So I guess the question is who do we use for language support EOLs?
> My understanding is that Ubuntu 18.04's default was 3.6 which has
> standard support until 2023[0] and CentOS Stream 8 will be supported
> until 2024[1].  Both of which should exceed Yoga's support[2]?  With
> all these arguments about LTS distros, it seems that we should be
> using their support life cyles for the language versions and not
> python's[3].

The answer is that it's not clear. We use the packaged Python 3
interpreter and standard library from specific LTS distros, but we
consume additional Python 3 library dependencies from PyPI rather
than from packages in those distros contemporary with the
interpreters they've packaged. The result is that we're stuck
relying on when those dependencies decide to drop support for what
they consider to be "old" interpreter versions.

At one time we tried to rely on distro packaged dependencies, but
discovered that breaks down as soon as projects want to use
libraries which aren't yet packaged in those distributions. It's
sort of Catch-22 in that the distros look to us to determine when
they should be adding or updating dependencies, so if we look to
them for which dependencies/versions are available then we can
quickly get deadlocked.
Jeremy Stanley
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 963 bytes
Desc: not available
URL: <>

More information about the openstack-discuss mailing list