[requirements][kuryr][flame] openshift dificulties

Clark Boylan cboylan at sapwetik.org
Wed May 29 22:30:20 UTC 2019

On Wed, May 29, 2019, at 1:54 PM, Matthew Thode wrote:
> Openshift upstream is giving us difficulty as they are capping the
> version of urllib3 and kubernetes we are using.
> -urllib3===1.25.3
> +urllib3===1.24.3
> -kubernetes===9.0.0
> +kubernetes===8.0.1
> I've opened an issue with them but not had much luck there (and their
> prefered solution just pushes the can down the road).
> https://github.com/openshift/openshift-restclient-python/issues/289
> What I'd us to do is move off of openshift as our usage doesn't seem too
> much.
> openstack/kuryr-tempest-plugin uses it for one import (and just one
> function with that import).  I'm not sure exactly what you are doing
> with it but would it be too much to ask to move to something else?
> x/flame has it in it's constraints but I don't see any actual usage, so
> perhaps it's a false flag.
> Please let me know what you think

I think part of the issue here is that the kubernetes lib is generated code and not "curated" with backward compatibility in mind. That said it is worth noting that the infra team found that openshift lib + kubernetes lib < 9.0 does not work with the ansible k8s modules (there is a bug in the blocking calls which causes them to go out to lunch and never return). Depending on where we pull these libraries in we may need to override anyway for things to function at all.


More information about the openstack-discuss mailing list