[placement][nova][ptg] resource provider affinity
balazs.gibizer at ericsson.com
Tue Apr 30 13:27:18 UTC 2019
On Mon, Apr 29, 2019 at 11:38 PM, Eric Fried <openstack at fried.cc> wrote:
>> Jay suggested extending the JSON schema to allow groups that are
>> names like resources_compute, required_network. That might allow for
>> some conventions to emerge but still requires some measure of
>> knowledge from the participants.
> I think this is a good idea to pursue, because it gives us a way to
> predefine (by convention) what the groups are called, as opposed to
> having them be automatically, arbitrarily, unpredictably numbered.
> still break down in more complex scenarios where, say, there's more
> one device_group with different affinity requirements; but it could
> for the simpler setups.
I support this idea. Today The RequestGroup contains a requester_id
field to map the numbered group back to the neutron port (cyborg
dev) it is originated from. If the group can be named instead of only
numbered then this mapping can be encoded into the name of the group
like resources_port_<port_uuid>. This would also made sure that name of
the group is unique and more importantly it is stable (today we
generate the number of the numbered group originated from neutron port)
and that helps troubleshooting.
More information about the openstack-discuss