<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
<body class='hmmessage'><div dir='ltr'>Thanks, Brandon.  <div>I am using V1. And trying to create via horizon, this field is the mandatory field in horizon creating pool page</div><div>Wanjing<br><br><div><hr id="stopSpelling">From: brandon.logan@RACKSPACE.COM<br>To: openstack-dev@lists.openstack.org<br>Date: Tue, 28 Apr 2015 01:40:00 +0000<br>Subject: Re: [openstack-dev] [Neutron][LBaaS] Why do we need to select subnet when creating a pool?<br><br>


<style style="display:none;">
.ExternalClass p {
}

.ExternalClass .ecxhmmessage p {
padding:0px;
}

.ExternalClass body.ecxhmmessage {
font-size:12pt;
font-family:Calibri;
}

</style>


I'm assuming you are using LBaaS V2.  With that assumption, I'm not sure how you are having to select subnet on the pool.  It's not supposed to be a field at all on the pool object.  subnet_id is required on the member object right now, but that's something
 I and others think should just be optional, and if not specified then it's assumed that member can be reached with whatever has already been setup.‚Äč  Another option is pool could get a subnet_id field in the future and all members that are created without
 subnet_id are assumed to be on the pool's subnet_id, but I'm getting ahead of myself and this has no bearing on your current issue.<br>
<BR>
<br>
<BR>
Could you tell me how you are making your requests? CLI? REST directly?<br>
<BR>
<div style="color:rgb(33, 33, 33);">
<hr tabindex="-1" style="display:inline-block;width:98%;">
<div id="ecxdivRplyFwdMsg" dir="ltr"><font face="Calibri, sans-serif" color="#000000" style="font-size:11pt;"><b>From:</b> Wanjing Xu <wanjing_xu@hotmail.com><br>
<b>Sent:</b> Monday, April 27, 2015 12:57 PM<br>
<b>To:</b> OpenStack Development Mailing List not for usage questions<br>
<b>Subject:</b> [openstack-dev] [Neutron][LBaaS] Why do we need to select subnet when creating a pool?</font>
<div> </div>
</div>
<div>
<div dir="ltr">So when I use Haproxy for LBaaS for Juno, there is a subnet mandatary field that I need to fill in when creating a pool, and later on when I add members, I can use a different subnet(or simply just enter the ip of the member), when adding vip,
 I can still select a third subnet.  So what is the usage of the first subnet that I used to create pool?  There is no port created for this pool subnet.  I can see that a port is created for the vip subnet that the loadbalancer instance is binding to.
<div><br>
</div>
<div>Regards!</div>
<div><br>
</div>
<div>Wanjing Xu</div>
</div>
</div>
</div>


<br>__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev</div></div>                                         </div></body>
</html>