[openstack-dev] [oslo] Can we stop global requirements update?
julien at danjou.info
Tue May 16 10:10:57 UTC 2017
On Tue, May 16 2017, Andreas Jaeger wrote:
> what exactly happened with Babel?
> I see in global-requirements the following:
> Babel>=2.3.4,!=2.4.0 # BSD
> that shouldn't case a problem - or does it? Or what's the problem?
Damn, at the moment I pressed the `Sent' button I thought "You just
complained without including much detail idiot". Sorry about that!
One of the log that fails:
Basically oslo.policy pulls oslo.i18n which pulls Babel!=2.4.0
But Babel is already pulled by os-testr which depends on >=2.3.4.
So pip does not solve that (unfortunately) and then the failure is:
2017-05-16 05:08:43.629772 | 2017-05-16 05:08:43.503 10699 ERROR gnocchi
ContextualVersionConflict: (Babel 2.4.0
I'm pretty sure Babel should not even be in the requirements list of
oslo.i18n since it's not a runtime dependency AFAIU.
/* Free Software hacker
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 800 bytes
Desc: not available
More information about the OpenStack-dev