[openstack-dev] [api][qa][tc][glance][keystone][cinder] Testing of deprecated API versions

Brian Rosmaita rosmaita.fossdev at gmail.com
Thu Mar 16 13:44:36 UTC 2017

Big snip ... the original message is here:

On 3/13/17 3:09 AM, Ghanshyam Mann wrote:
> On Sat, Mar 11, 2017 at 12:10 AM, Andrea Frittoli <andrea.frittoli at gmail.com
>> wrote:
>> On Fri, Mar 10, 2017 at 2:49 PM Andrea Frittoli <andrea.frittoli at gmail.com>
>> wrote:
>> Of course Glance v1 still has to run on the stable/newton gate jobs, until
>> Newton EOL (TBD), so tests will stay in Tempest for a cycle more at least.
>> I guess I shouldn't be sending emails on a Friday afternoon?
> ​humm, Till Mitaka right? Newton version of glance is with v1 API as
> deprecated. And Mitaka is v1 as supported APIs so we only need to care
> about Mitaka where v1 APIs were supported and keep tests till Mitaka EOL.

(Sorry for the lateness of my reply, I was under the weather earlier
this week.)

Glance v1 is a special case, because even though it's DEPRECATED, out of
courtesy to operators, we won't remove it until some specific features
(primarily, image import with copy-from) are available in v2.  We'd
originally thought that this feature was unnecessary, but heard
differently from operators once v1 went into deprecation.  Thus, through
the Ocata release, there are valid reasons for operators to deploy v1
even though it's deprecated.  We didn't un-deprecate v1 because we
wanted to send a clear message that v1 is definitely going away.

So, it's important that v1 continue to be tested in the gate.


More information about the OpenStack-dev mailing list