[openstack-dev] [oslo][requirements][all] requesting assistance to unblock SQLAlchemy 1.1 from requirements

Mike Bayer mbayer at redhat.com
Wed Mar 15 14:38:43 UTC 2017

On 03/15/2017 07:30 AM, Sean Dague wrote:
> The problem was the original patch kept a cap on SQLA, just moved it up
> to the next pre-release, not realizing the caps in general are the
> concern by the requirements team. So instead of upping the cap, I just
> removed it entirely. (It also didn't help on clarity that there was a
> completely unrelated fail in the tests which made it look like the
> system was stopping this.)
> This should hopefully let new SQLA releases very naturally filter out to
> all our services and libraries.
> 	-Sean

so the failure I'm seeing now is *probably* one I saw earlier when we 
tried to do this, the tempest run fails on trying to run a keystone 
request, but I can't find the same error in the logs this time.

In an earlier build of https://review.openstack.org/#/c/423192/, we saw 

ContextualVersionConflict: (SQLAlchemy 1.1.5 
Requirement.parse('SQLAlchemy<1.1.0,>=1.0.10'), set(['oslo.db', 

stack trace was in the apache log:  http://paste.openstack.org/show/601583/

but now on our own oslo.db build, the same jobs are failing and are 
halting at keystone, but I can't find any error:

the failure is:


and is on:  https://review.openstack.org/#/c/445930/

if someone w/ tempest expertise could help with this that would be great.

More information about the OpenStack-dev mailing list