[openstack-dev] Error with gerrit, devstack

Clark Boylan cboylan at sapwetik.org
Fri Dec 9 17:18:05 UTC 2016

On Fri, Dec 9, 2016, at 09:11 AM, Annapoornima Koppad wrote:
> Dear All,
> I am facing this problem with Devstack Gerrit process. Can someone help?
> Here is my problem. I had an old machine on which I installed git, git
> cloned Devstack and contributed some patches to Openstack. My old machine
> was as useless as it could get. So, I bought a new Dell Inspiron machine
> and installed Ubuntu 16.04. I git cloned Devstack again, and installed
> git.
> I uploaded the SSH keys to https://review.openstack.org/#/settings/. I
> tried to hook up Gerrit with git so that I could start working on patches
> as well. When I did the following:
> git review -s
> I ran into the following problem.
> Problem running 'git remote update gerrit'
> Fetching gerrit
> fatal: unable to access
> 'https://annakoppad@review.openstack.org:29418/openstack-dev/devstack.git/':
> gnutls_handshake() failed: An unexpected TLS packet was received.
> error: Could not fetch gerrit
> Problems encountered installing commit-msg hook
> The following command failed with exit code 255
> "GET
> https://annakoppad@review.openstack.org:29418/tools/hooks/commit-msg"
> -----------------------
> ("bad handshake: Error([('SSL routines', 'SSL23_GET_SERVER_HELLO',
> 'unknown protocol')],)",)
> My git config --list looks like this.
> user.name=Annapoornima Koppad
> user.email=annakoppad at gmail.com
> gitreview.username=annakoppad
> core.repositoryformatversion=0
> core.filemode=true
> core.bare=false
> core.logallrefupdates=true
> remote.origin.url=https://git.openstack.org/openstack-dev/devstack
> remote.origin.fetch=+refs/heads/*:refs/remotes/origin/*
> branch.master.remote=origin
> branch.master.merge=refs/heads/master
> remote.gerrit.url=https://annakoppad@review.openstack.org:29418/openstack-dev/devstack.git

Port 29418 is an ssh port, not an https port. You should run https on
the default port, 443. Alternately use ssh:// instead of https://.

> remote.gerrit.fetch=+refs/heads/*:refs/remotes/gerrit/*
> y local.conf looks like this.
> [[local|localrc]]
> ADMIN_PASSWORD=****************
> DATABASE_PASSWORD=****************
> RABBIT_PASSWORD=****************
> SERVICE_PASSWORD=****************
> GIT_BASE=${GIT_BASE:-https://git.openstack.org}
> I restarted the machine if the changes could start again. That did not
> work.
> What is that I am missing?

I think if you get the connection protocol and ports to line up as above
that should make git review happy.


More information about the OpenStack-dev mailing list