[openstack-dev] [networking-odl] Neutron with OpenDaylight Boron controller

Elena Ezhova eezhova at mirantis.com
Wed Dec 7 12:20:37 UTC 2016

Hi folks,

We are trying to deploy Neutron with OpenDaylight Boron-0.5.0 controller
using DevStack (master version) on Ubuntu 14.04 and there is a number of
issues we face.

First, we tried to deploy OpenDaylight with odl-ovsdb-openstack feature
using the following local.conf [0]. In this case VMs successfully got IP
addresses and L2 connectivity was working, but there was no L3 connectivity
meaning we couldn't ping router IP from qdhcp namespace and VMs in
different subnets couldn't reach each other.
We've also tried to deploy OpenDaylight odl-ovsdb-openstack with Neutron L3
agent by enabling q-l3 and setting ODL_L3=False in local.conf, but in this
case stack.sh failed due to br-int not having been created.

After that, we were given an advice on opendaylight irc channel to use
odl-netvirt-openstack feature instead as odl-ovsdb-openstack is kind of
When deploying Neutron+ODL with this feature we were referencing the
NetVirt demo from the latest ODL summit [1] as well as networking-odl
DevStack guide [2] and our local.conf was looking the following way [3].
As a result, though br-int is created and when a subnet or a VM are created
corresponding tap interfaces are added, there is no L2 and L3 connectivity
and there are a lot of error in karaf logs:

   - Errors on start: http://paste.openstack.org/show/591432/
   - Logs during Neutron subnet create:
   - OVS ports and flows after a Neutron network with a subnet were
   created: http://paste.openstack.org/show/591642/ .
   Here it seems that not all flows had been created, for example there is
   a flow in table 51 that sends traffic to table 52 which is missing.
   - There are also tons of traces identical to ones in bug [4] which
   should have been fixed in Beryllium release.

Has someone successfully deployed operational Neutron+OpenDaylight with
NetVirt or ovsdb feature recently? If so, we would really appreciate an
example of local.conf that was used as well as any clues that point out
what we can be missing.


[0] http://paste.openstack.org/show/591645/
[3] http://paste.openstack.org/show/591641/
[4] https://bugs.opendaylight.org/show_bug.cgi?id=5275
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20161207/d9256da6/attachment.html>

More information about the OpenStack-dev mailing list