[openstack-dev] [ironic][OpenStackClient] two openstack commands for the same operation?
ruby.loo at intel.com
Mon Aug 29 14:41:01 UTC 2016
In ironic, we have these ironic CLI commands:
- ironic node-vendor-passthru (calls the specified passthru method)
- ironic node-get-vendor-passthru-methods (lists the available passthru methods)
For their corresponding openstackclient plugin commands, we (I, I guess) have proposed :
- openstack baremetal node passthrough call
- openstack baremetal node passthrough list
I did this because 'passthrough' is more English than 'passthru' and I thought that was the 'way to go' in osc. But some folks wanted it to be 'passthru' because in ironic, we've been calling them 'passthru' since day 2. To make everyone happy, I also proposed (as aliases):
- openstack baremetal node passthru call
- openstack baremetal node passthru list
Unfortunately, I wasn't able to make everyone happy because someone else thinks that we shouldn't be providing two different openstack commands that provide the same functionality. (They're fine with either one, just not both.)
What do the rest of the folks think? Some guidance from the OpenStackClient folks would be greatly appreciated.
More information about the OpenStack-dev