[openstack-dev] Devstack liberty with keystone v3

Perry, Sean sean.perry at hpe.com
Mon Apr 25 23:48:26 UTC 2016

The trick is to let devstack install and then switch openrc to IDENTITY_API_VERSION=3. Both v2 and v3 endpoints are created already. The tools just need to be told to use them.

From: kiran vemuri UH [kkvemuri at uh.edu]
Sent: Monday, April 25, 2016 4:10 PM
To: openstack-dev at lists.openstack.org
Subject: [openstack-dev] Devstack liberty with keystone v3

Hello All,

I recently got started with OpenStack with a goal of bringing up a multi region setup i.e., 2 regions using the same keystone service.

I started with devstack liberty stable release by following the documentation available at: http://docs.openstack.org/developer/devstack/#configuration

I am able to bring up the liberty but it boots with keystone v2 as default. Could anyone please point me to the documentation on how to enable keystone v3?

I tried making changes to local.conf file with the following parameters.


but, everytime I do unstack and stack, it results in error similar to this https://bugs.launchpad.net/devstack/+bug/1490950

I also tried solutions listed in the above bug.. but nothing helped.

Could anyone help me out with this?

Kiran Vemuri

kiran vemuri
Tel: (832)-701-8281
kkvemuri at uh.edu<mailto:kkvemuri at uh.edu>

More information about the OpenStack-dev mailing list