[openstack-dev] [Congress] Issues with Tox testing

Bryan Sullivan blsaws at hotmail.com
Thu Apr 7 23:29:56 UTC 2016

An update: I found that there were two dependencies needed that were not clear in the guide at https://github.com/openstack/congress. I also installed Tempest which was not referenced before. If these additions are correct (they worked for me), they should be added to https://github.com/openstack/congress/blob/master/README.rst.

$ sudo apt-get install libffi-dev libssl-dev
$ cd ~/git
$ git clone https://github.com/openstack/tempest/
$ cd tempest
$ ~/git/congress/bin/pip install -r requirements.txt
$ ~/git/congress/bin/pip install .

(not sure if both pip commands are needed - I'm not an expert on pip install)

After that, "tox -epy27" ran thru fine:

-------------------------------------------------------------------------------------------------------  -----------
congress.tests.policy_engines.test_vmplacement.TestComputeVmAssignment.test_set_policy_with_dashes       27.623
congress.tests.policy_engines.test_vmplacement.TestComputeVmAssignment.test_set_policy                   27.212
congress.tests.policy_engines.test_agnostic_performance.TestRuntimePerformance.test_simulate_latency      1.325
congress.tests.dse.test_dse.TestDSE.test_policy_tables                                                    1.229
congress.tests.policy_engines.test_agnostic_performance.TestRuntimePerformance.test_select_100matches     1.184
congress.tests.test_congress.TestCongress.test_policy_execute                                             1.127
congress.tests.test_congress.TestCongress.test_datasource_api_model_execute                               1.067
congress.tests.policy_engines.test_agnostic_performance.TestRuntimePerformance.test_update_nonrecursive   0.967
congress.tests.dse.test_dse.TestDSE.test_policy_table_publish                                             0.681
congress.tests.datasources.test_neutron_driver.TestDataSourceDriver.test_poll_subscribe                   0.671
______________________________________________________________ summary _______________________________________________________________
  py27: commands succeeded
  congratulations :)

Bryan Sullivan

From: blsaws at hotmail.com
To: openstack-dev at lists.openstack.org
Date: Thu, 7 Apr 2016 11:16:48 -0700
Subject: [openstack-dev] [Congress] Issues with Tox testing

Hi Congress team, 

A question for tox testing expert on the Congress team. I'm trying to run the tox tests as described at https://github.com/openstack/congress, specifically the two commands:

$ sudo pip install 'tox<1.7'

$ tox -epy27 

Due to conflicts with the OS-owned python config, I run these under my virtualenv created in the congress repo as:
$ cd ~/git/congress
$ bin/pip  install 'tox<1.7'
$ bin/tox -epy27

But in any event (whether I try to run the tox within the virtualenv or not), I get errors such as:
  c/_cffi_backend.c:15:17: fatal error: ffi.h: No such file or directory

What's missing in the setup for running these tests? 

Note that I have all the config needed to run bash/CLI-based test scripts such as https://git.opnfv.org/cgit/copper/tree/tests/adhoc/dmz01.sh 

Bryan Sullivan 		 	   		  

OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request at lists.openstack.org?subject:unsubscribe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20160407/823e6fe1/attachment.html>

More information about the OpenStack-dev mailing list