[openstack-dev] [oslo.messaging] Why the needed version of kombu to support heartbeat is >=3.0.7
appleorchard2000 at gmail.com
Wed Oct 28 06:15:51 UTC 2015
Thank you for pointing this out, dims. I didn't notice this process of
openstack. But i wonder how do you find the relationship between that bot's
commit and the global requirements commit.
And sileht, from this commit
there seems not a robust reason to require kombu >= 3.0.7.
It's because ubuntu Trusty's default kombu version is 3.0.7, and it works
with amqp 1.4.0, right?
On Wed, Oct 28, 2015 at 12:46 PM, Davanum Srinivas <davanum at gmail.com>
> "Bot with No reason" <<< Not really accurate. The process in openstack is
> to update global requirements first and then bot proposes the update to
> different projects. So please look at
> for the commit which updated the global requirements
> On Wed, Oct 28, 2015 at 1:07 PM, me,apporc <appleorchard2000 at gmail.com>
>> Thanks again.
>> This kombu >=3.0.7 requirement is added in commit
>> 5b9fb6980220dbfa18bac4c3231d57efb493ebf0, which is from a Bot with no
>> As i see, we are directly requiring amqp >=1.4.0 in requirement.txt from
>> commit 0c954cffa2f3710acafa79f01b958a8955823640 on.
>> So maybe there is no need to require kombu >= 3.0.7 ?
>> Another reason I am asking about this, in the latest centos 7 epel repo,
>> the versions of these two packages are :
>> python-kombu : 2.5.16-1.el7
>> python-amqp : 1.4.5-1.el7
>> I have not test whether there are problems about heartbeat with this
>> version pair though.
>> On Tue, Oct 27, 2015 at 11:02 PM, Mehdi Abaakouk <sileht at sileht.net>
>>>  seems just socket timeout issue, and admins can adjust those kernel
>>>> params themselves.
>>> Yes, but if you trick kernel settings, like putting very low tcp
>>> keepalive values, you don't need to have/enable heartbeat.
>>>  and  truly a problem about the heartbeat implementation, but it
>>>> the fix is a part of py-amqp 1.4.0, and the dependency with kombu was
>>>>  is a bug of kombu's autoretry method which is said to be fixed in
>>>> 3.0.0, it is not directly related to heartbeat.
>>> As far as I can remember, this is because oslo.messaging doesn't really
>>> require py-amqp but only kombu, so to ensure kombu depends of py-amqp 1.4.0
>>> we have to depends on kombu 3.0.7 (that have amqp>=1.4.0 in its
>>> requirements I guess).
>>> Mehdi Abaakouk
>>> mail: sileht at sileht.net
>>> irc: sileht
>> OpenStack Development Mailing List (not for usage questions)
>> OpenStack-dev-request at lists.openstack.org?subject:unsubscribe
> Davanum Srinivas :: https://twitter.com/dims
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: OpenStack-dev-request at lists.openstack.org?subject:unsubscribe
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the OpenStack-dev