[openstack-dev] [oslo.messaging] Why the needed version of kombu to support heartbeat is >=3.0.7

me,apporc appleorchard2000 at gmail.com
Wed Oct 28 04:07:39 UTC 2015

Thanks again.

This kombu >=3.0.7 requirement is added in commit
5b9fb6980220dbfa18bac4c3231d57efb493ebf0, which is from a Bot with no

 As i see, we are directly requiring amqp >=1.4.0 in requirement.txt from
commit 0c954cffa2f3710acafa79f01b958a8955823640 on.
So maybe there is no need to require kombu >= 3.0.7 ?

Another reason I am asking about this, in the latest centos 7 epel repo,
the versions of these two packages are :
python-kombu : 2.5.16-1.el7
python-amqp : 1.4.5-1.el7

I have not test whether there are problems about heartbeat with this
version pair though.

On Tue, Oct 27, 2015 at 11:02 PM, Mehdi Abaakouk <sileht at sileht.net> wrote:

> [1] seems just socket timeout issue, and admins can adjust those kernel
>> params themselves.
> Yes, but if you trick kernel settings, like putting very low tcp keepalive
> values, you don't need to have/enable heartbeat.
> [2] and [3] truly a problem about the heartbeat implementation, but it says
>> the fix is a part of py-amqp 1.4.0, and the dependency with kombu was not
>> specified.
>> [4] is a bug of kombu's autoretry method which is said to be fixed in
>> kombu
>> 3.0.0, it is not directly related to heartbeat.
> As far as I can remember, this is because oslo.messaging doesn't really
> require py-amqp but only kombu, so to ensure kombu depends of py-amqp 1.4.0
> we have to depends on kombu 3.0.7 (that have amqp>=1.4.0 in its
> requirements I guess).
> ---
> Mehdi Abaakouk
> mail: sileht at sileht.net
> irc: sileht

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20151028/9597efd5/attachment.html>

More information about the OpenStack-dev mailing list