[openstack-dev] [packaging] liberty doesn't have caps on deps

Robert Collins robertc at robertcollins.net
Thu Oct 15 19:04:24 UTC 2015

On 16 October 2015 at 08:01, Matthew Thode <prometheanfire at gentoo.org> wrote:
> So, this is my perspective in packing liberty for Gentoo.
> We can have multiple versions of a package available to install, because
> of this we generally directly translate the valid dependency versions
> from requirements.


> this
>     oslo.concurrency>=2.3.0 # Apache-2.0
> becomes this
>     >=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
> Now what happens when I package something from mitaka (2.7.0 in this
> case would be mitaka).  It's undefined behaviour as far as I know.
> Basically, I can see no reason why the policy of caps changed from kilo
> to liberty, it was actually nice to package for liberty, I can see this
> going very bad very quick.

They changed because it was causing huge trauma and multiple day long
gate wedges around release times. Covered in detail here -

> Where are my caps?

The known good versions of dependencies for liberty are

You should be able to trivially pull those versions out and into your
liberty set of packages.

Theres another iteration on this in discussion now, which has to do
with backwards compat *and testing of cap changes*, we'll be in the
backwards compat fishbowl session in Tokyo if you're interested.


Robert Collins <rbtcollins at hp.com>
Distinguished Technologist
HP Converged Cloud

More information about the OpenStack-dev mailing list