[openstack-dev] [Zaqar][cli][openstackclient] conflict in nova flavor and zaqar flavor
sbaker at redhat.com
Tue Oct 13 21:32:11 UTC 2015
On 14/10/15 10:15, Dean Troyer wrote:
> On Tue, Oct 13, 2015 at 3:58 PM, Shifali Agrawal
> <shaifali.agrawal09 at gmail.com <mailto:shaifali.agrawal09 at gmail.com>>
> All above make sense, just one thing, how about using word "zaqar"
> instead of messaging? That is what all other projects are doing,
> for example:
> These are the old project-specific CLIs, note that the 'keystone'
> command only supports v2 auth today and will be removed entirely in
> the keystoneclient 2.0 release.
> $ keystone user-create
> $ heat event-list
> This will create a separate namespace for the project and also
> will solve the issue of `openstack messaging message post`.
> One of the things I have tried very hard to do is make it so users do
> NOT need to know which API handles a given command. For higher-layer
> projects that is less of a concern I suppose, and that was done long
> before anyone thought that 20+ APIs would be handled in a single
> command set.
> Namespacing has come up and is something we need to discuss further,
> either within the 'openstack' command itself or by using additional
> top-level command names. This is one of the topics for discussion in
> Tokyo, but has already started on the ML for those that will not be
> No matter how we end up handling the namespacing issue, I will still
> strongly insist that project code names not be used. I know some
> plugins already do this today and we can't stop anyone else from doing
> it, but it leads to the same sort of inconsistency for users that the
> original project CLIs had. It reduces the value of a single (or small
> set of) CLI for the user to deal with.
I would agree with Dean here. "messaging" is a service, not a thing the
service provides. I'd like to think that commands can be built using a
list of nouns, with the first noun making it sufficiently obvious of the
general family of things you're working on. "queue" seems to fit as the
first noun in this case, so how about:
openstack queue post
openstack queue pool flavor create
openstack queue pool flavor get
openstack queue pool flavor delete
openstack queue pool flavor update
openstack queue pool flavor list
openstack queue pool create
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the OpenStack-dev