[openstack-dev] [Kuryr] tox -egenconfig not working

Vikas Choudhary choudharyvikas16 at gmail.com
Mon Oct 5 04:49:48 UTC 2015


For me also its working on my host machine which already had devstack
running. Its failing in case when i am trying on newly launched
virtual-box vm. On host machine(where its working) may be requirements
installed by devstack for some other projects helping kuryr tox. I
even tried copying working tox directory from host to vm and then
running genconfig , still that did not help.


On terminal it is not dumping any other error message than "ERROR:
could not install deps [-r/home/ubuntu/kuryr/requirements.txt,
-r/home/ubuntu/kuryr/test-requirements.txt". I was not sure but still
i gave a try and installed libjpeg-dev, but no help.

Can anybody please guide me how to debug this like on what dependency
it is failing? Where tox is dumping error messages?

 Thanks & Regards



If its because of an Error like "ValueError: --enable-jpeg requested
but jpeg not found, aborting² triggered by a dependency pull of
Python pillow which then I got around it by doing an ³apt-get install
libjpeg-dev² on my ubuntu build.
I agree its seemed odd when it happened on tox but not on pip but I
noticed it was during the documentation tests.

On 10/1/15, 7:20 PM, "Michal Rostecki" <mrostecki at mirantis.com

*>>*On Wed, Sep 30, 2015 at 2:27 PM, Vikas Choudhary
*>*<choudharyvikas16 at gmail.com
*>>* Hi,
*>>>>* I tried to generate sample kuryr.using "tox -e genconfig", but it is
*>>* failing:
*>>>>* genconfig create: /home/vikas/kuryr/.tox/genconfig
*>>* genconfig installdeps: -r/home/vikas/kuryr/requirements.txt,
*>>* -r/home/vikas/kuryr/test-requirements.txt
*>>* ERROR: could not install deps [-r/home/vikas/kuryr/requirements.txt,
*>>* -r/home/vikas/kuryr/test-requirements.txt]
*>>* ___________________________________________________________________
*>>* ___________________________________________________________________
*>>* ERROR:   genconfig: could not install deps
*>>* [-r/home/vikas/kuryr/requirements.txt,
*>>* -r/home/vikas/kuryr/test-requirements.txt]
*>>>>* ________________________________________________________
*>>*Command "tox -e genconfig" is working perfectly for me. Please:
*>*- ensure you have up-to-date repo
*>*- try to remove .tox/ directory and run the command again
*>>>>>* But if i run "pip install -r requirements.txt", its giving no error.
*>>*Does "pip install -r test-requirements.txt" give no error as well?
*>>>>>* How to generalr sample config file? Please suggest.
*>>>>>>* -Vikas
*>*Michal Rostecki
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20151005/5a1a8584/attachment.html>

More information about the OpenStack-dev mailing list