[openstack-dev] Fedora 21 Kubernetes 0.15.0 Image Status

Steven Dake (stdake) stdake at cisco.com
Thu Apr 23 14:53:05 UTC 2015


Copying openstack-dev mailing list – hope you don’t mind.

Folks, we are talking about the images here:


Specifically the images with “15” in the filename.

Feel free to test these images as your leisure.

From: Madhuri Rai <madhuri.rai07 at gmail.com<mailto:madhuri.rai07 at gmail.com>>
Date: Thursday, April 23, 2015 at 4:20 AM
To: Steven Dake <stdake at cisco.com<mailto:stdake at cisco.com>>
Subject: Fedora 21 Kubernetes 0.15.0 Image Status

Hi Steven,

Feel free to call me steve :)

I created a vm with image created by you and found some failure.
Please have a look below:

[minion at f21-k8s15 ~]$ sudo systemctl | grep fail
● docker.service                                                                      loaded failed failed    Docker Application Container Engine


When I boot the vm locally in virtualbox this problem doesn’t happen.  Can you run sudo systemctl status docker.service when this occurs and debug further?  Journalctl –uctl I think (may not be correct options) will give more debug output.  We need to get to the root cause of this problem.


Check out this ask post and see if your regionone is setup properly


However I was able to enable docker service manually.
I also tried some of the commands like pod, service and rc create and that succeeds.

That is good news, that means kubernetes is working :)

Important point to be noted is Yuanying also tried to create a vm. And there the systemctl doesn't show any failure but the cloud-init-output.logs were same as mine(it failed to connect to metadata server).

Thanks & Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20150423/6a5de60f/attachment.html>

More information about the OpenStack-dev mailing list