[openstack-dev] [oslo] dropping namespace packages
doug at doughellmann.com
Wed Nov 12 20:32:12 UTC 2014
We rather quickly came to consensus at the summit that we should drop the use of namespace packages in Oslo libraries . As far as I could tell, everyone was happy with my proposed approach  of moving the code from oslo.foo to oslo_foo and then creating a backwards-compatibility shim in oslo.foo that imports public symbols from oslo_foo. We also agreed that we would not rename existing libraries, and we would continue to use the same naming convention for new libraries. So the distribution and git repository both will be called “oslo.foo” and the import statement would look like “from oslo_foo import bar”.
More information about the OpenStack-dev