[openstack-dev] Devstack on Fedora 20

Flavio Percoco flavio at redhat.com
Fri Jan 10 09:54:32 UTC 2014

On 09/01/14 23:27 -0500, Adam Young wrote:
>On 01/09/2014 04:58 PM, Sean Dague wrote:
>    On 01/09/2014 04:12 PM, Dean Troyer wrote:
>        On Thu, Jan 9, 2014 at 2:16 PM, Adam Young <ayoung at redhat.com
>        <mailto:ayoung at redhat.com>> wrote:
>            That didn't seem to make a difference, still no cache.  The RPMS are
>            not getting installed, even if I deliberately add a line for
>            python-dogpile-cache
>            Shouldn't it get installed via pip without the rpm line?
>        Yes pip should install it based on requirements.txt.  I just tried this
>        and see the install in /opt/stack/logs/stack.sh.log and then see the
>        import fail later.  God I love pip.  And there it is...xslt-config isn't
>        present so a whole batch of installs fails.
>        Add this to files/rpms/keystone:
>        libxslt-devel       # dist:f20
>        There are some additional tweaks that I'll ask Flavio to add
>        to https://review.openstack.org/63647 as it needs at least one more
>        patch set anyway.
>    So that would be the work around if the rpm doesn't work, but I really
>    think we should use the rpm instead. I'm sort of confused that it didn't
>    get picked up.
>    Got more detailed output Adam?
>            -Sean
>    _______________________________________________
>    OpenStack-dev mailing list
>    OpenStack-dev at lists.openstack.org
>    http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>Let me see...
>I erased the two rpms and reran unstack then
>seems to have worked.  I have a running Keystone.  Let me try again on a virgin
>Nope...with that patch applied, I have not python-lxml or python-dogpile-cache
>Tried wiping out the (installed) python-greenlet rpm and re running, and that
>was not installed afterwards, either.  I am guessing that the package install
>step is getting skipped somehow, after the first run.

I just updated the patch with the latest feedback from this thread.
Could you give it a try again?


Flavio Percoco
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20140110/9d59b97e/attachment.pgp>

More information about the OpenStack-dev mailing list