[openstack-dev] Devstack on Fedora 20

Adam Young ayoung at redhat.com
Thu Jan 9 19:15:07 UTC 2014

So finally tried running a devstack instance on Fedora 20:  rootwrap 
failed on the cinder stage of the install.  So I scaled back to a 
Keystone only install.

[fedora at ayoung-f20 devstack]$ cat localrc

This failed starting the Keystone server with two module dependencies 
missing:  first was dogpile.cache, and second was lxml.  I installed 
both with Yum and devstack completed with Keystone up and running:  I 
was able to fetch a token.

Dogpile is in the requirements.txt file, but not in the list of RPMS to 
install for devstack.  I tried adding it to devstack/files/rpms. lxml 
was already in there:  Neither was installed.

  (requirements.txt state that Keystone needs dogpile.cache >= 0.5.0 
which is what F20 has in Yum)

What am I missing here?

[fedora at ayoung-f20 devstack]$ git diff
diff --git a/files/rpms/keystone b/files/rpms/keystone
index 52dbf47..deed296 100644
--- a/files/rpms/keystone
+++ b/files/rpms/keystone
@@ -1,5 +1,6 @@
+python-dogpile-cache #dist:f20
-python-lxml         #dist:f16,f17,f18,f19
+python-lxml         #dist:f16,f17,f18,f19,f20
  python-paste        #dist:f16,f17,f18,f19
  python-paste-deploy #dist:f16,f17,f18,f19
  python-paste-script #dist:f16,f17,f18,f19

More information about the OpenStack-dev mailing list