[openstack-dev] olso.config error on running Devstack

Ben Nemec openstack at nemebean.com
Wed Jan 8 17:37:53 UTC 2014

On 2014-01-08 11:16, Sean Dague wrote:
> On 01/08/2014 12:06 PM, Doug Hellmann wrote:
> <snip>
>> Yeah, that's what made me start thinking oslo.sphinx should be called
>> something else.
>> Sean, how strongly do you feel about not installing oslo.sphinx in
>> devstack? I see your point, I'm just looking for alternatives to the
>> hassle of renaming oslo.sphinx.
> Doing the git thing is definitely not the right thing. But I guess I 
> got
> lost somewhere along the way about what the actual problem is. Can
> someone write that up concisely? With all the things that have been
> tried/failed, why certain things fail, etc.

The problem seems to be when we pip install -e oslo.config on the 
system, then pip install oslo.sphinx in a venv.  oslo.config is 
unavailable in the venv, apparently because the namespace package for 
o.s causes the egg-link for o.c to be ignored.  Pretty much every other 
combination I've tried (regular pip install of both, or pip install -e 
of both, regardless of where they are) works fine, but there seem to be 
other issues with all of the other options we've explored so far.

We can't remove the pip install -e of oslo.config because it has to be 
used for gating, and we can't pip install -e oslo.sphinx because it's 
not a runtime dep so it doesn't belong in the gate.  Changing the 
toplevel package for oslo.sphinx was also mentioned, but has obvious 
drawbacks too.

I think that about covers what I know so far.


More information about the OpenStack-dev mailing list