[openstack-dev] New python dependency - extras-0.0.1
dprince at redhat.com
Tue Jan 15 15:33:45 UTC 2013
----- Original Message -----
> From: "Pádraig Brady" <P at draigBrady.com>
> To: "OpenStack Development Mailing List" <openstack-dev at lists.openstack.org>
> Sent: Thursday, December 13, 2012 4:58:07 AM
> Subject: Re: [openstack-dev] New python dependency - extras-0.0.1
> On 12/12/2012 11:02 PM, Robert Collins wrote:
> > On Thu, Dec 13, 2012 at 6:45 AM, Brian Waldon <bcwaldon at gmail.com>
> > wrote:
> >> I want to agree loudly with this - the name 'extras' is a little
> >> silly. I'm fine with the underlying code, but it needs a much
> >> more descriptive name.
> >>>> I'm inclined to approve it, just want to give folks a chance to
> >>>> express
> >>>> an opinion.
> >>> How about pulling try_import() into olso for the moment?
I missed this thread initially. A month later when the new python-extras code hit Quantum I thought it was a bit overkill as well so I did this (which has now landed):
> >> This seems like a good compromise to forcing you (and others) to
> >> package something not everybody really agrees on.
> > testtools, which is already a dependency, will start depending on
> > extras in a release or so (giving folk time to package it). So you
> > won't avoid any packaging work by copying it into oslo - but you
> > will
> > incur technical debt by copying the code.
One fine point I would make about the teststools dependency (if/when it does happen)... this is a test time dependency and would only need to go in tools/test-requires. So there is still benefit in avoiding the use of python-extra's in our runtime code (users won't have to maintain/deploy the "extra" package).
> It's just that python-extras pushed the boundaries
> on naming, size and even need.
> Naming is too generic great as mentioned before.
> Size is tiny, so separation cost may outweigh advantages.
> Need may be short term too. If tools progress
> to handling this common renaming pattern, the need diminishes
> Maybe testtools could continue as it does now,
> and in future if a separate try_import() is needed,
> then it can take it from the standard lib or
> somewhere else more cohesive and substantive.
++ I fully agree.
> OpenStack-dev mailing list
> OpenStack-dev at lists.openstack.org
More information about the OpenStack-dev