[openstack-dev] Glance hang uploading images

McHale, Therese therese.mchale at hp.com
Tue Jan 15 11:53:19 UTC 2013


Api log shows:

>>2013-01-14 18:42:56.18 DEBUG glance.registry.client [ab1e07b0-97fa-4508-96ac-1d6375282271 1947906b9e9f42e7bdfd29c9219fcda0 1e80f28a9dd1425bb905c1192317cfb2] 
>>Registry request PUT /images/f5a9f8c4-b82b-4192-8379-cb4619bff1d6 HTTP 200 request id req-81b04d9c-0672-4b50-b450-9eb3a764bcdc do_request >>/home/berrange/src/cloud/glance/glance/registry/client.py:95

Looks like the put of the image worked.

But there is this:

>>No handlers could be found for logger "qpid.messaging"

Registry log shows:

>>2013-01-14 18:42:56.16 INFO glance.registry.api.v1.images [81b04d9c-0672-4b50-b450-9eb3a764bcdc 1947906b9e9f42e7bdfd29c9219fcda0 1e80f28a9dd1425bb905c1192317cfb2] >>Updating metadata for image f5a9f8c4-b82b-4192-8379-cb4619bff1d6 

Looks ok.  If you set this in default_log_levels:    eventlet.wsgi.server=DEBUG,sqlalchemy.DEBUG   I would see more debug, i.e. see the full
Sql resultset to confirm everything returned ok from sql/see more wsgi output.  (This is what was changed in the patch)

On the qpid/messaging  error...were you getting this before the problem?
I'm not using qpid messaging/just using the defaults in the example conf file (e.g. qpid_host=localhost for me as this is what is in the
Example glance-api.conf,  whereas you use - I think correctly based on the code -  qpid_hostname=localhost, you also have qpid_notificaton_topic=notifications
Whereas this is set to 'glance_notifications' on my system.)

If you log a bug for this and add the extra debug there I can look at it there.


-----Original Message-----
From: Daniel P. Berrange [mailto:berrange at redhat.com] 
Sent: 14 January 2013 18:49
To: McHale, Therese
Cc: openstack-dev at lists.openstack.org
Subject: Re: Glance hang uploading images

On Mon, Jan 14, 2013 at 03:33:16PM +0000, McHale, Therese wrote:
> Hi Daniel,
> We've had this in production for sometime (slight different patch on 
> diablo )  and on folsom code base without issues. (Ubuntu natty and 
> precise) Is this specific to Fedora 18? (i.e. do you know if it is 
> reproducible on Fedora 16 for
> Example?)
> The code change reverts a previous change to use multiple wsgi apps 
> for glance (which was a fix for an Issue with multiple worker threads) 
> Instead it uses one wsgi app but uses one database engine per worker 
> process so that Database sessions do not become muddled.
> Are you saying all uploading fails on Fedora 18 i.e. Glance does not 
> work on Fedora1 17 or that after a certain period it fails.
> How many registry, glance api processes are you using and if you set 
> debugging (sql also)

It fails the moment you trying to upload an image, eg

 # glance add name=f16-jeos is_public=true disk_format=qcow2 container_format=bare < files/f16-x86_64-openstack-sda.qcow2 

I've not tried on any other Fedora version. The config file settings are all the defaults as set by devstack. I've not modified the number of registry/api processes.

> Whats in the logs?

The logs are attached here - this is recording from the startup of glance to the hang occurring

|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|

More information about the OpenStack-dev mailing list