[openstack-dev] Catalog type naming guidelines
jaypipes at gmail.com
Tue Dec 10 16:56:48 UTC 2013
On 12/10/2013 09:57 AM, Sergey Lukjanov wrote:
> we have a concern about the correct catalog type naming for projects
> who'd like to have a name like "data processing". It looks like space
> char is not the best choice, so, mainly we're trying to choose between
> '-' and '_'. Currently only only swift has an catalog type named with
> '-': 'object-store' and other projects are avoiding separators
> ('cloudformation') or just doesn't have such need. So, we have a concern
> about the correct naming of savanna catalog type ('data_processing' is
> currently used in devstack).
> Are there any thoughts on it?
> Thank you!
> P.S. Personally, I'm thinking about 'data_processing' because I prefer
> the '_' in names and it was already landed to the devstack as part of
> savanna support. In addition 'keystone service-create
> --name=data_processing' looks more readable for me.
Unless there's a good reason, I think it's probably best to stick with
the existing convention (using '-' instead of '_'). I think in these
cases, consistency trumps preference :)
All the best,
More information about the OpenStack-dev