[openstack-dev] ./run_tests.sh fails with "db type could not be determined" error

Sumanth Suresh Nagadavalli sumansn at thoughtworks.com
Thu Aug 29 14:11:57 UTC 2013


>From sometime today, I am not any more able to run ./run_tests.sh. It gives
the following error,

*Running `tools/with_venv.sh python setup.py testr --testr-args='--subunit
*db type could not be determined*
*error: testr failed (3)*
*Ran 0 tests in 6.989s*

I tried recreating my virtual environment, running tests with/without site
packages but the result was same.

When I run tests with -d(debug) option, I see the below error.

*ERROR: unittest.loader.ModuleImportFailure.virt.xenapi.test_xenapi*
*ImportError: Failed to import test module: virt.xenapi.test_xenapi*
*Traceback (most recent call last):*
*  File
line 252, in _find_tests*
*    module = self._get_module_from_name(name)*
*  File
line 230, in _get_module_from_name*
*    __import__(name)*
*  File "/Users/sumansn/Work/nova/nova/tests/virt/xenapi/test_xenapi.py",
line 43, in <module>*
*    from nova import test*
*  File "nova/test.py", line 52, in <module>*
*    from nova.tests import conf_fixture*
*  File "nova/tests/__init__.py", line 39, in <module>*
*    % os.environ.get('EVENTLET_NO_GREENDNS'))*
*ImportError: eventlet imported before nova/cmd/__init__ (env var set to

My python version is 2.7.3 and I am using a Mac OSx 10.7.5

Has anything changes recently that I have to account for? Any help would be

Sumanth N S
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20130829/e01f1169/attachment.html>

More information about the OpenStack-dev mailing list